Author Topic: How to debug a report with exceptions which causes a core dump in cognos 8.4.1 ?  (Read 4853 times)

Offline Ucat

  • Full Member
  • ***
  • Join Date: Feb 2009
  • Posts: 10
  • Forum Citizenship: +1/-0
I have been experiencing a series of core memory dumps caused by the PowerPlay web service when the users run a particular report.

Is there a way to debug the report to find out what is causing the portal failure ?
The core dump files are useless because our local Cognos provider doesn't have the tools or necessary knowledge to open them.
 
The user receives a message saying that the query is too complex and there is not enough memory to complete the task.

Please, can you help me with this problem ?

Thanks in advance.




Offline AussiePete2011

  • Statesman
  • ******
  • Join Date: Feb 2011
  • Posts: 311
  • Forum Citizenship: +19/-0
Hi there

I know there are defects on this around drill through.  If you know what circumstances cause the cores then you can lodge a PMR with IBM to get the hotsites

To turn on ppds debugging go to
../<Cognosinstall>/Configuration
Locate the ppds_cfg.xml.sample file
Make a copy
Rename the file to ppds_cfg.xml
Open the file in a text editor
Find the section as below
<!-- Enabling PPDS logging when using PowerPlay Client or PowerPlay Studio.
     queryLogFile is the full path and name of the log file and when specified will turn on logging.
     There is no default log file name. To turn off logging, leave this parameter as an empty string.
     LogFunctionNames controls whether PPDS logs the PPDS function name or internal code.
     Default value is 1, which logs functions by name.  When set to 0, the numerical internal function code will be logged.
-->
      <Section value="PowerPlay DataServer">
         <queryLogFile value=""/>
         <LogFunctionNames value="1"/>
      </Section>
<!-- -->
Enter a log path
Restart the C8 services
If you know how to replicate the core then do that and you'll have generated the ppds.log file which can be used to see what was used and where it stopped prior to the core.

I'm betting this is a drill through issue but see how you go
Cheers
Peter B

Offline shaik.cog

  • Associate
  • **
  • Join Date: Mar 2011
  • Posts: 1
  • Forum Citizenship: +0/-0
In Report studio I have a problem,i.e In my report page have 3 pages
(Ex: list,Cross Tab,Chart) But 2nd Page(Cross tab) does't have any data.If i run report empty page could not visible. how can handle that process.can u give reply Clearly

 


       
Twittear