Author Topic: Cognos 10 Framework Manager problem  (Read 5660 times)

Offline redraven71

  • Full Member
  • ***
  • Join Date: Aug 2011
  • Posts: 12
  • Forum Citizenship: +0/-0
Cognos 10 Framework Manager problem
« on: 22 Aug 2012 01:35:43 pm »
Our Cognos 10 environment is working well with one exception.  I have moved all the Cognos 8 framework manager projects to the Cognos 10 server, opened all of them, and saved them with no issues.  Today, I need to update a query subject within a project, and when I try to add a new item from the data source, I get several errors.  QE-DEF-0285, QE-DEF-0325, RQP-DEF-0068, UDA-SQL-0031 (all have to do with logon to the database failing) and UDA-SQL-0107 (general exception error) and ORA-06413 (connection not open).  The framework manager software and projects are installed/saved on the same machine as the cognos 10 install.  The  machine is a 64 bit windows 2008 r2 machine running oracle client 10.2.0. 

Any suggestions are greatly appreciated.  Thanks! 

RR

Offline tjohnson3050

  • IBM Certified Solution Expert - Cognos BI
  • Statesman
  • ******
  • Join Date: Dec 2011
  • Posts: 370
  • Forum Citizenship: +63/-0
  • The only dumb question is the one never asked.
    • Linked In Profile
Re: Cognos 10 Framework Manager problem
« Reply #1 on: 22 Aug 2012 05:00:17 pm »
Did you test the Oracle configuration (tnsping the service name)?  I have been guilty in the past of installing the Oracle client but not moving over the configuration files (tnsnames.ora)...

Offline redraven71

  • Full Member
  • ***
  • Join Date: Aug 2011
  • Posts: 12
  • Forum Citizenship: +0/-0
Re: Cognos 10 Framework Manager problem
« Reply #2 on: 23 Aug 2012 08:49:12 am »
I compared the tnsnames files between Cognos 8 environment and Cognos 10.  The only thing I can't check right now is the Cognos 8 development environment.  It is currently down due to hardware issues.  Once it is back up, I will double check the tnsnames file there as well.  This was my first thought as well.  As of right now, the tnsnames files on cog 10 and cog 8 production are the same.  It will let me publish a package in cog 10, but it doesn't like it if I try to change anything within the project. 

Thank you for your reply.  :)

Offline tjohnson3050

  • IBM Certified Solution Expert - Cognos BI
  • Statesman
  • ******
  • Join Date: Dec 2011
  • Posts: 370
  • Forum Citizenship: +63/-0
  • The only dumb question is the one never asked.
    • Linked In Profile
Re: Cognos 10 Framework Manager problem
« Reply #3 on: 23 Aug 2012 10:32:05 am »
There are several things that can be different about connecting to Oracle between Cognos 8 and Cognos 10.

One common issue is that in changing from Cognos 8 to Cognos 10, the underlying server architecture also changes from 32 bit to 64 bit. 

http://www-01.ibm.com/support/docview.wss?uid=swg21370380

Also if you are going to try to use the new Dynamic Query Mode, you will need to become familiar with connecting to Oracle via JDBC.

http://www-01.ibm.com/support/docview.wss?uid=swg21573898

Other Oracle connection troubleshooting

http://www-01.ibm.com/support/docview.wss?uid=swg21341734

 


       
Twittear