Author Topic: CCLAssertError:0:Fatal: CCL_ASSERT_NAMED(FALSE, "RSAOMSchemaTypesFactory::a  (Read 2320 times)

Offline rameshmessages

  • Associate
  • **
  • Join Date: Aug 2013
  • Posts: 2
  • Forum Citizenship: +0/-0
upgrading the java application which accesses CognosReports v 8.4 from lower ver

I have replaced old jars with new jars
old jars => axis.jar, axisReportNetClient.jar
new jars => axis.jar, axisCrnpClient.jar

updated the package names from

import com.cognos.developer.schemas.bibus._2.AsynchStatusEnum;
import com.cognos.developer.schemas.bibus._2.BaseClass;
import com.cognos.developer.schemas.bibus._2.CognosReportNetPortType;
import com.cognos.developer.schemas.bibus._2.CognosReportNetServiceLocator;
import com.cognos.developer.schemas.bibus._2.Parameter;
import com.cognos.developer.schemas.bibus._2.ParameterValue;
import com.cognos.developer.schemas.bibus._2.ParmValueItem;
import com.cognos.developer.schemas.bibus._2.ReportServiceResponse;
import com.cognos.developer.schemas.bibus._2.ReportVersion;
import com.cognos.developer.schemas.bibus._2.RunOption;
import com.cognos.developer.schemas.bibus._2.RunOptionBoolean;
import com.cognos.developer.schemas.bibus._2.RunOptionEnum;
import com.cognos.developer.schemas.bibus._2.RunOptionStringArray;
import com.cognos.developer.schemas.bibus._2.SimpleParmValueItem;
to
import com.cognos.developer.schemas.bibus._3.AsynchStatusEnum;
import com.cognos.developer.schemas.bibus._3.BaseClass;
import com.cognos.developer.schemas.bibus._3.CognosReportNetPortType;
import com.cognos.developer.schemas.bibus._3.CognosReportNetServiceLocator;
import com.cognos.developer.schemas.bibus._3.Parameter;
import com.cognos.developer.schemas.bibus._3.ParameterValue;
import com.cognos.developer.schemas.bibus._3.ParmValueItem;
import com.cognos.developer.schemas.bibus._3.ReportServiceResponse;
import com.cognos.developer.schemas.bibus._3.ReportVersion;
import com.cognos.developer.schemas.bibus._3.RunOption;
import com.cognos.developer.schemas.bibus._3.RunOptionBoolean;
import com.cognos.developer.schemas.bibus._3.RunOptionEnum;
import com.cognos.developer.schemas.bibus._3.RunOptionStringArray;
import com.cognos.developer.schemas.bibus._3.SimpleParmValueItem;

Connected to Cognos Server and getting the below error message

<SOAP-ENV:Body><SOAP-ENV:Fault><SOAP-ENV:faultcode>SOAP-ENV:Server</SOAP-ENV:faultcode><SOAP-ENV:faultstring>Server Error</SOAP-ENV:faultstring><SOAP-ENV:detail><bus:exception>               <bus:severity xsi:type="xs:string">Fatal</bus:severity>
               <bus:errorCode xsi:type="xs:string">0</bus:errorCode>
               <bus:message xsi:type="bus:message">
                  <bus:messageString xsi:type="xs:string">RSV-SRV-0040 An application error has occurred. Contact your Administrator.</bus:messageString>
                  <bus:nestingLevel xsi:type="xs:integer">1</bus:nestingLevel>
               </bus:message>
               <bus:message xsi:type="bus:message">
                  <bus:messageString xsi:type="xs:string">CCLAssertError:0:Fatal: CCL_ASSERT_NAMED(FALSE, &quot;RSAOMSchemaTypesFactory::arrayTypeToObjectType(): unknown xsi:type: &quot;);</bus:messageString>
                  <bus:nestingLevel xsi:type="xs:integer">1</bus:nestingLevel>
               </bus:message>
               <bus:message xsi:type="bus:message">
                  <bus:messageString xsi:type="xs:string">RSV-SRV-0042 Trace back:</bus:messageString>
                  <bus:nestingLevel xsi:type="xs:integer">1</bus:nestingLevel>
               </bus:message>
               <bus:message xsi:type="bus:message">
                  <bus:messageString xsi:type="xs:string">RSReportService.cpp(802): CCLAssertError: CCL_CAUGHT: RSReportService::process()</bus:messageString>
                  <bus:nestingLevel xsi:type="xs:integer">1</bus:nestingLevel>
               </bus:message>
               <bus:message xsi:type="bus:message">
                  <bus:messageString xsi:type="xs:string">RSReportService.cpp(897): CCLAssertError: CCL_RETHROW: RSReportService::parse()</bus:messageString>
                  <bus:nestingLevel xsi:type="xs:integer">1</bus:nestingLevel>
               </bus:message>
               <bus:message xsi:type="bus:message">
                  <bus:messageString xsi:type="xs:string">RSAOMSOAPMessageIDeserializer.cpp(139): CCLAssertError: CCL_RETHROW: RSAOMSOAPMessageIDeserializer::parse()</bus:messageString>
                  <bus:nestingLevel xsi:type="xs:integer">1</bus:nestingLevel>
               </bus:message>
               <bus:message xsi:type="bus:message">
                  <bus:messageString xsi:type="xs:string">RSAOMSchemaTypesFactory.cpp(17745): CCLAssertError: CCL_THROW: </bus:messageString>
                  <bus:nestingLevel xsi:type="xs:integer">1</bus:nestingLevel>
               </bus:message>
</bus:exception></SOAP-ENV:detail></SOAP-ENV:Fault></SOAP-ENV:Body>

Is there anything missing or need to change or any options/solutions.
Please help us in resolving this issue..

 


       
Twittear