Author Topic: blank data in query subject  (Read 1123 times)

Offline ry1633

  • Statesman
  • ******
  • Join Date: Apr 2015
  • Posts: 278
  • Forum Citizenship: +0/-1
blank data in query subject
« on: 13 May 2016 12:01:55 pm »
Hi all,   I have a user who gets blank data when she pulls in a particular query subject into Query Studio - there's nothing there at all.   But it works just fine for all of the other users on their own browsers and is working just fine for me too.    We have a suspicion it might be a browser/security setting, but haven't found it out yet.      We are all using IE 11 with the latest patches in a Windows 7 64 bit environment.

Offline bus_pass_man

  • Community Leader
  • *****
  • Join Date: May 2008
  • Posts: 243
  • Forum Citizenship: +30/-0
Re: blank data in query subject
« Reply #1 on: 13 May 2016 03:58:11 pm »
Some ideas:

1.  What does the SQL look like for this user?   Does it match what is generated when other users use the same objects in a query?

2.  Is this user a member of a group or role which is denied access to the data via a security filter?

3.  Control for the browser by:
       i. Having the user log in to another browser and/or log in onto another machine and see if the results are reproducible.
       ii. Clear the browser cache.

4.  Just query studio or the other studios too?

I'd start at 1.   The information there might be useful.

Offline ry1633

  • Statesman
  • ******
  • Join Date: Apr 2015
  • Posts: 278
  • Forum Citizenship: +0/-1
Re: blank data in query subject
« Reply #2 on: 16 May 2016 01:16:09 pm »
1.  We've compared the SQL side-by-side from different users and it isn't any different

2. No

3. It works fine in Firefox but not in IE

4.  They only have access to Query Studio right now.

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 9,864
  • Forum Citizenship: +597/-9
  • Cognos Software Muppet
Re: blank data in query subject
« Reply #3 on: 17 May 2016 04:25:13 am »
1.  We've compared the SQL side-by-side from different users and it isn't any different

2. No

3. It works fine in Firefox but not in IE

4.  They only have access to Query Studio right now.

Has the user switched on Compatability Mode in IE? This is required for Query Studio...

MF.
Meep!

Offline ry1633

  • Statesman
  • ******
  • Join Date: Apr 2015
  • Posts: 278
  • Forum Citizenship: +0/-1
Re: blank data in query subject
« Reply #4 on: 17 May 2016 12:16:01 pm »
Checked compatibility mode in IE and all is well there too.

 


       
Twittear