Author Topic: Unable to see the Schme while creating a data module  (Read 339 times)

Offline superman99

  • Full Member
  • ***
  • Join Date: Nov 2013
  • Posts: 23
  • Forum Citizenship: +0/-0
Unable to see the Schme while creating a data module
« on: 13 Nov 2016 02:02:26 pm »
Hello Gurus,

I have read the following topic http://www.cognoise.com/index.php/topic,31241.0.htmland I am facing somewhat a similar issue. I have installed CA 11.0.4, tested the connection successfully but I am unable to see the schemas, it shows "Results are empty". I have followed all the technotes but none of them helped me. http://www-01.ibm.com/support/docview.wss?uid=swg21973943
I have tried connecting it through FM where I am getting the following error
I am using Oracle Oracle 10gR2. I have just read on the following topic http://www.cognoise.com/index.php/topic,31241.0.html that CA only supports 12cR1 & 11gR2. Does it mean any other versions of Oracle are not supported?
I opned a PMR with IBM which took a lot of time and was not able to solve the issue.

Tried using FM but still no luck

I will really appreciate your feedback.

Thanks
« Last Edit: 13 Nov 2016 02:04:10 pm by superman99 »

Online MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 9,299
  • Forum Citizenship: +563/-8
  • Cognos Software Muppet
Re: Unable to see the Schme while creating a data module
« Reply #1 on: 14 Nov 2016 03:33:32 am »
Hello Gurus,

I have read the following topic http://www.cognoise.com/index.php/topic,31241.0.htmland I am facing somewhat a similar issue. I have installed CA 11.0.4, tested the connection successfully but I am unable to see the schemas, it shows "Results are empty". I have followed all the technotes but none of them helped me. http://www-01.ibm.com/support/docview.wss?uid=swg21973943
I have tried connecting it through FM where I am getting the following error
I am using Oracle Oracle 10gR2. I have just read on the following topic http://www.cognoise.com/index.php/topic,31241.0.html that CA only supports 12cR1 & 11gR2. Does it mean any other versions of Oracle are not supported?
I opned a PMR with IBM which took a lot of time and was not able to solve the issue.

Tried using FM but still no luck

I will really appreciate your feedback.

Thanks

Hi,

I don't think Oracle 10 has a JDBC driver that is compliant with JRE8 (Cognos Analytics uses JRE8). Assuming I'm correct, your only option is to upgrade to Oracle 11 or Oracle 12.

Cheers!

MF.
Meep!

Offline superman99

  • Full Member
  • ***
  • Join Date: Nov 2013
  • Posts: 23
  • Forum Citizenship: +0/-0
Re: Unable to see the Schme while creating a data module
« Reply #2 on: 19 Nov 2016 04:20:12 am »
Thanks MFGF for your prompted response.

I was able to connect to Oracle 10gR2 using ojdbc7.jar but it is not recommended because the risk here is that Cognos query generation is based on the functionality of the Oracle 11 product, there's an outside chance that some of the SQL we generate may not work correctly.

 


           
Twittear