Author Topic: Compatibility: FM 11 model vs. FM 10 model  (Read 351 times)

Offline dougp

  • Community Leader
  • *****
  • Join Date: Jul 2014
  • Posts: 107
  • Forum Citizenship: +7/-0
Compatibility: FM 11 model vs. FM 10 model
« on: 23 Nov 2016 03:44:54 pm »
I found an article on this topic comparing version 10 to version 8 (http://www.cognoise.com/index.php/topic,18143.msg52974.html#msg52974) and, since I just needed this information for my current effort, I thought it would be good to add this post in case someone else needs it.

According to http://www.ibm.com/support/knowledgecenter/SSEP7J_10.2.2/com.ibm.swg.ba.cognos.dg_fm_sdk.10.2.2.doc/r_dg_fm_sdk_mdlref_model_reference.html, BMTModelSpecification.xsd can be found at installation_location\templates\bmt\Cr1Model.  Comparing my 11.0.4 schema with my 10.2.1 schema, I see that there have been two data types changed and a handful of features added.

Models saved in 11.0.4 are not compatible with 10.2.1 and should not be edited in FM 10.2.1.

However, FM 10.2.1 doesn't keep you from opening the newer model.  Actually, here's how it works:

The xml namespace for a 10.2.1 model is http://www.developer.cognos.com/schemas/bmt/60/7, where 7 appears to be the model version number.

Save a model in 10.2.1.  Version is 7.
Open the model in 11.0.4 and save.  Version is 11.
Open the model in 10.2.1.  It opens with no errors are warnings.  Save.  Version is now 71.
Open the model in 11.0.4.  FM tells you, "The project was created with a more recent version of IBM Cognos Framework Manager."

It looks like FM 10.2.1 looks at a string of length x and checks the value of the last character.  Since 1 is smaller than 7, all is well.  Saving, it changes the first x characters to include the 7 on the end.  Since the new string is longer, it ignores the trailing 1.  FM 11.0.4 thinks the model was created in FM version 71, so it won't open it.

 


           
Twittear