Author Topic: Cognos 11.0.5 Stand Alone Installation  (Read 276 times)

Offline adam.johnson

  • Full Member
  • ***
  • Join Date: Sep 2016
  • Posts: 9
  • Forum Citizenship: +0/-0
Cognos 11.0.5 Stand Alone Installation
« on: 16 Feb 2017 03:34:48 am »
Cognos Version: 11R5 (Stand Alone)
Operating System: Win 2012
Web Service: IIS 8.5

Upon starting the Cognos Service no errors are apparent, however, when accessing CA through Internet Explorer (via http://<server_name>/ibmcognos/bi/) I receive the following error:


Installation Information Error
A failure occurred while retrieving the installation environment. Some features may not be available. The root cause is the following: Error 404: javax.servlet.ServletException: java.io.FileNotFoundException: SRVE0190E: File not found: /keys/Glass/installMode


Any help would be appreciated as currently Google only provides resolutions for WebSphere, however, the CA Service is using WebSphere Liberty Profile rather than the full WebSphere service.

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 9,354
  • Forum Citizenship: +567/-8
  • Cognos Software Muppet
Re: Cognos 11.0.5 Stand Alone Installation
« Reply #1 on: 16 Feb 2017 03:39:56 am »
Cognos Version: 11R5 (Stand Alone)
Operating System: Win 2012
Web Service: IIS 8.5

Upon starting the Cognos Service no errors are apparent, however, when accessing CA through Internet Explorer (via http://<server_name>/ibmcognos/bi/) I receive the following error:


Installation Information Error
A failure occurred while retrieving the installation environment. Some features may not be available. The root cause is the following: Error 404: javax.servlet.ServletException: java.io.FileNotFoundException: SRVE0190E: File not found: /keys/Glass/installMode


Any help would be appreciated as currently Google only provides resolutions for WebSphere, however, the CA Service is using WebSphere Liberty Profile rather than the full WebSphere service.

Hi,

This looks like the same issue as detailed in the very next post to this one?

http://www.cognoise.com/index.php/topic,32394.0.html

Try using the URL http://<server_name>:9300/bi/

If you need to use IIS, there's a quite involved process to set it up, but if the above URL (the servlet gateway) works for you, then there may be no need...

MF.
Meep!

Offline adam.johnson

  • Full Member
  • ***
  • Join Date: Sep 2016
  • Posts: 9
  • Forum Citizenship: +0/-0
Re: Cognos 11.0.5 Stand Alone Installation
« Reply #2 on: 16 Feb 2017 03:50:31 am »
MFGF

Thank you for the response, can you confirm if I did not install the optional gateway would I not need to configure IIS?

Would Cognos work out of the box without any need for IIS (or other tool) configuration using the default values of <server_name>:9300/bi/

As per the post linked, am a little confused with this approach coming from a Cognos 8 / 10 admin background.

Adam

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 9,354
  • Forum Citizenship: +567/-8
  • Cognos Software Muppet
Re: Cognos 11.0.5 Stand Alone Installation
« Reply #3 on: 16 Feb 2017 05:23:01 am »
Thank you for the response, can you confirm if I did not install the optional gateway would I not need to configure IIS?

That's correct - you only need to configure a web server such as IIS if you need to use the optional gateway.

Would Cognos work out of the box without any need for IIS (or other tool) configuration using the default values of <server_name>:9300/bi/

Yes it would (and does). The URL above connects to the baked-in servlet gateway, which gives you access without needing a web server.

As per the post linked, am a little confused with this approach coming from a Cognos 8 / 10 admin background.

Back in the days of Cognos 8, web server access via the gateway was commonly required. It was possible to connect via the dispatcher URL, but you had to copy a collection of stuff to other folders in the install in order to see something that looked normal.
In Cognos 10.2.2, the concept of using the servelet gateway (ie direct dispatcher connection) rather than the regular gateway and a web server was made easier. There was an option on the install to run a "Quick Setup", which installed the servlet gateway (among other things) and meant there was no need for a web server.
In Cognos 11 (Cognos Analytics) the default is now that the servlet gateway is used. Installing the optional gateway component for use with a web server is an option you can choose if you really want to, but there's often no need to do this. The need to use single signon would be an instance where you might need to.

Cheers!

MF.
Meep!

 



           
Twittear