If you are unable to create a new account, please email support@bspsoftware.com



MetaManager - Administrative Tools for IBM Cognos
Pricing starting at $2,100
Download Now    Learn More

Main Menu

Same Prompt Name Not Applying to all Widgets

Started by gpollock, 04 Jan 2018 09:51:58 AM

Previous topic - Next topic


I'm struggling with using a prompt widget from a report.  I would like to build a dashboard for a user that has widgets from two different reports and filtered by a prompt widget from one of the reports, and am getting an error message.  I'm on 10.2.2.

Here's what I did:
1) Created a Report Studio report off a relational package, and created a couple crosstabs and a chart within this report.  The queries for these items all have a detail filter with a parameter called "Year" off a data item also called "Year".
[RMS].[RMS Executive Reports].[Year]=?Year?
2) Generated a prompt page and a simple value prompt in the same report for (1).  Prompt was given a name so it could be imported to workspace.
3) Brought these items into workspace as widgets.  I did rename the value prompt item (not the data items or prompt name in the filter) to "Select Year" just so I can have the title display it.  So far everything is working as expected.
4) Created a new Report Studio report off a dynamic cube, and used a simple crosstab with a drill down.  Created a Slicer Member set (even though I tried to make it a single item) on the "Loss Year" Hierarchy of the "Loss Date" dimension.  Like (1), the parameter is named "Year".
set([Claims].[Loss Date].[Loss Date].[Loss Year]->?Year?)
5) The report in 4 will run without issue.  But when I try to import this into Workspace, I get the error below, and listening is disabled on this item.  I can confirm that if I enable listening on the cube crosstab for "Select Year", changing the year in "Select Year" will attempt to filter it, but throw this error again.
6) If I generate a prompt page and value prompt for the dynamic cube report, just like in (2), I can import this prompt to workspace, and it will successfully filter the cube crosstab, but now this new prompt will cause the relational report objects to throw the same error.  Plus, I don't want to have two prompts each asking the user to select the year.

I think the problem has to do with passing the values, but they are both "Year" values with INT data types.  I also tried converting the cube slicer to a detail filter (don't tell Paul), and get the same problem.  Is there something I need to do to make objects from different reports work together?

QuoteRSV-SRV-0042 Trace back:
RSReportService.cpp(763): XQEException: CCL_CAUGHT: RSReportService::processImpl()
RSReportServiceMethod.cpp(259): XQEException: CCL_RETHROW: RSReportServiceMethod::process(): asynchRunSpecification_Request
RSASyncExecutionThread.cpp(864): XQEException: RSASyncExecutionThread::checkException
RSASyncExecutionThread.cpp(319): XQEException: CCL_CAUGHT: RSASyncExecutionThread::runImpl(): asynchRunSpecification_Request
RSASyncExecutionThread.cpp(909): XQEException: CCL_RETHROW: RSASyncExecutionThread::processCommand(): asynchRunSpecification_Request
Execution/RSRenderExecution.cpp(600): XQEException: CCL_RETHROW: RSRenderExecution::execute
Assembly/RSDocAssemblyDispatch.cpp(340): XQEException: CCL_RETHROW: RSDocAssemblyDispatch::dispatchAssembly
Assembly/RSLayoutAssembly.cpp(79): XQEException: CCL_RETHROW: RSLayoutAssembly::assemble
Assembly/RSDocAssemblyDispatch.cpp(446): XQEException: CCL_RETHROW: RSDocAssemblyDispatch::dispatchChildrenAssemblyForward
Assembly/RSReportPagesAssembly.cpp(185): XQEException: CCL_RETHROW: RSReportPagesAssembly::assemble
Assembly/RSDocAssemblyDispatch.cpp(384): XQEException: CCL_RETHROW: RSDocAssemblyDispatch::dispatchAssembly
Assembly/RSPageAssembly.cpp(314): XQEException: CCL_RETHROW: RSPageAssembly::assemble
Assembly/RSDocAssemblyDispatch.cpp(384): XQEException: CCL_RETHROW: RSDocAssemblyDispatch::dispatchAssembly
Assembly/RSTableRowAssembly.cpp(177): XQEException: CCL_RETHROW: RSTableRowAssembly::assemble
Assembly/RSDocAssemblyDispatch.cpp(384): XQEException: CCL_RETHROW: RSDocAssemblyDispatch::dispatchAssembly
Assembly/RSTableCellAssembly.cpp(151): XQEException: CCL_RETHROW: RSTableCellAssembly::assemble
Assembly/RSDocAssemblyDispatch.cpp(446): XQEException: CCL_RETHROW: RSDocAssemblyDispatch::dispatchChildrenAssemblyForward
Assembly/RSDocAssemblyDispatch.cpp(384): XQEException: CCL_RETHROW: RSDocAssemblyDispatch::dispatchAssembly
RSQueryMgr.cpp(636): XQEException: CCL_RETHROW: RSQueryMgr::getResultSetIterator
RSQueryMgr.cpp(744): XQEException: CCL_RETHROW: RSQueryMgr::createIterator
RSQueryMgrBasic.cpp(290): XQEException: CCL_RETHROW: RSQueryMgrBasic::executeRsapiCommand
RSQueryMgrExecutionHandlerImpl.cpp(174): XQEException: CCL_RETHROW: RSQueryMgrExecutionHandlerImpl::execute()
QFSSession.cpp(1162): XQEException: CCL_RETHROW: QFSSession::ProcessDoRequest()
QFSSession.cpp(1160): XQEException: CCL_CAUGHT: QFSSession::ProcessDoRequest()
QFSSession.cpp(1117): XQEException: CCL_RETHROW: QFSSession::ProcessDoRequest()
QFSConnection.cpp(888): XQEException: CCL_RETHROW: QFSConnection::Execute
QFSQuery.cpp(311): XQEException: CCL_RETHROW: QFSQuery::Execute v2
XQEConnector.cpp(300): XQEException: CCL_THROW: XQEConnector::send


I am also having the same issue but "year" is a reserved keyword in Cognos.


Check the second to last word. I'm not sure how you could escape it. I changed the word slightly but it's still reacting similarly.


The year in a cube cannot be retrieved as an INT because its will be enclosed in square brackets and that's why caption is used to eliminate the brackets. Just passing this but not sure if that will resolve this problem. Not sure what you are trying to do but if it requires using relational as well as dimensional functions in the same query or passing relational and dimensional functions together then that can definitely throw errors.