If you are unable to create a new account, please email support@bspsoftware.com



MetaManager - Administrative Tools for IBM Cognos
Pricing starting at $2,100
Download Now    Learn More

Main Menu

[MM] issue stagging kpi value [solved]

Started by francois, 26 Jun 2007 05:40:59 AM

Previous topic - Next topic



C8metrics issue stagging kpi value and time mapping

My company is running the brand new Cognos8 version 2, the data source is SQL2005 isp plugged to PeopleSoft and we publish in the content store using framework manager.

I've got no problem with framework, report studio, event manager etc.

We've created a metric store on a seperate database (env. sql2005 sp2) using the script included into the C8 install package (an other way to do it).

I'm facing the following problem with metric studio and metric manager :

Creating a new metric extract in a metric package i'm able to retrieve published C8 package,
navigate in it and retrieve meta, values, creating metrics type etc. reffering to a chosen scorecard.
Also the time mapping is working perfectly wether the source is a relational or a multidimensional one.
I'm able to run and load to the stagging area the metric meta and kpi values and publish to the metric store.
But having a look into kpi_value_stage or kpi_value_stage_rejects it appears the time ref. portion of the lines is all NULL (year_nr, time_period_cd, etc.).
As a consequence i'm unlikely to retrieve kpis values while running the calculate metrics into cognos studio maintenance, but the Meta only (adding new trees to the chosen scorecard).

I've read all the KB relative to that pb ( none ) and had a Cognos support in house for the same result.

Anybody's help will be really welcomed as i've got a projet review coming and users pushing hard to get their metrics working  .


Solved :

Olap Measures must be set has "calculated" rather than any other rule in the property tab.

Sum, average etc. works only with framework based Measures.


Excellent.  Thanks for the follow up with the solution to your issue.


Late validation but just to confirm : yes, that was the problem. Using "calculated" make it works.


Hello everybody,

I've got a similar problem like francois's one.

I made a new Metric Extract from a Molap source.
In the new Metric Extract wizard, I'm able to set scorecard tree, time mapping, mew metric type and measure field (calculated in transformer) like a metric.
I'm also able to execute the new Metric Extract without errors and after that to run the tranfer data from staging areas into Metric store.
The problem is that when I open Metric Studio I'm only able to see metadata and not values in metrics: it means it shows correctly all scorecard tree and metric features for each one, but each metric is without values.

I can't understand why it can't load data in metrics....hope anybody can halp me!!

Thanks to all!!!



This topic help me a lot in developing my project. I will contribute more when I finished it.

If you want to get more materials that related to this topic, you can visit: KPI metrics

Best regards.