If you are unable to create a new account, please email support@bspsoftware.com



MetaManager - Administrative Tools for IBM Cognos
Pricing starting at $2,100
Download Now    Learn More

Main Menu

Can't add column to query???

Started by dfite, 06 Sep 2007 01:58:39 PM

Previous topic - Next topic


This one is just so weird.  I created an oracle table, then a query subject in FM, then started building a report qith query1 having all of the query subject's data items.  I then realized that I was missing a column, so I went back in to Oracle and added the column, then edited the query subject in FM, saved and republished, and went back into report (closed and re-opened).  In FM I tested the Query subject and saw contents in my new column.  I added the new column, which displayed in the model, to the qurey1 and I get an error:

QE-DEF-0177 An error occurred while performing operation 'sqlPrepareWithOptions' status='-205'. UDA-SQL-0191 The column "CALCID2" was not found in the table or view "RPT_RPT_998_MAIN2".

I can't get around it!  Also, my query subject is named RPT$, NOT RPT_!!  I deleted the QS and re-created it in FM under a new name and dropped the query1 in the report and tried to load the new QS as query1 and it STILL doesn't recognize the new column.  I verified the column DOES exist in Oracle, and tests ok in FM.  What the heck else must I do to convince Cognos that the column IS there???!?!?!? 


oh my goodness...  I had to clear my local cache and then report studio recognized that the column WAS there...  unbelievable...


Are you talking about your browser cache?  I'm getting the same error and can't find the solution.


I know this topic is over 2 years old but I found it while researching the same problem.

I'm creating cognos reports for PTC Windchill which is slightly different then the straight to oracle most posts I see. I was seeing the same error though after adding a column of data. It had been working and then I changed things made some tweeks and it acted like the data column didn't exist. I restarted tomcat flushed its work folder, restarted windchill, cleared my browser cache nothing same problem. It seemed to really not like me selecting the page and the changing the data to my query and then changing properties to the column I wanted data from - that specifically broke it.

I restarted the cognos server and it worked. What a piece of trash this software is. I agree with all others on the message boards I read - this software gives terrible feedback with no way good ways to debug and track issues down. It is super buggy and picky and has more quirks then dustin hoffman in rainman.


A user of mine has this same issue, while I can run the same report without any issues. What are the exact steps this user has to take? I prefer not to restart the Cognos production environment during office hours.
Few can be done on Cognos | RTFM for those who ask basic questions...