If you are unable to create a new account, please email support@bspsoftware.com



MetaManager - Administrative Tools for IBM Cognos
Pricing starting at $2,100
Download Now    Learn More

Main Menu

Generate Transformer model failed

Started by Roman, 13 Dec 2016 01:00:37 PM

Previous topic - Next topic


Hello Everyone!  :)

Glad to share with you an one interesting issue.
Spent 2 days without any result to create the model using the Planning Contributor administration - get following errror "An error creating the model has occured" (a screenshot attached).
Have tried a lot of solutions :
1) reinstall the Java and Oracle DB client
2) install a new version of Oracle DB client
3) install the Java SDK with JAVA_HOME variable
4) reinstall the Transformer
5) increase/decrease the memory allocated for Java in the configuration
6) change the BI path directly to Transformer folder in the Planning configuration
7) checking all possible log files
8) checking the ODBC drivers, etc.
Nothing helped :(

The Transformer works fine if start it standalone.

Have you faced with something similar? ???

P.S. Using the shared environment of Planning 10.2 & Analytics 11.0.4 - all works fine, except mentioned above. The FM using the wizard was created fine.

Thanks for your advice!


One more interesting surprise:
Have just tried to create the transformer model from Analyst directly - started with the publish of D-cube, trying 4x times and every time had this issue:
A fatal error has occurred. Dyalog APL cannot continue.
In workspace C:\Cognos\planning\bin\PLANNING.DWS (process ID:9364)
Syserror: 999 code: 0
Interpreter BuildID: 0xab0f8715
Interpreter Created: Feb  3 2014 at 17:21:12
Interpreter Version / 32 / Classic

If you choose to generate an aplcore, it will be saved as: "C:\Cognos\planning\bin\aplcore".
It may be possible to retrieve objects from this file using:
)COPY C:\Cognos\planning\bin\aplcore.

APL Stack trace->
#.EXPORT.StartPublish[26] data,,oModel.Publish((#._US.bsl folder),'analyst\settings')#._US.Language usr pwd data
#.run[27] ŒDQ'.'
#._LX[86] ...run‡done
<-End of APL Stack trace
Tried the publishing a simple d-cube with 2 d-lists only (w/o any special characters) - got the same error...
So, at least using the CAC can hopefully publishing the table layout but can't generate the transformer, in the Analyst can't even launch the publish process...
What's going on... :o :o :o
Have you any ideas?


Sorry to be unhelpful but suspect you may need to raise IBM support call.



Hi Roman - did you get a response on this from IBM? I have the same issue right now