Planning & Consolidation > COGNOS Planning

Planning Analyst 10.1.1 - Disappearing d-links


I was doing some clean-up, and deleted 2 d-links.  Analyst immediately shut down, and when I reopened, ALL the d-links were gone!
Almost all the d-links are used in macros, so I opened one of the macros, and tried to edit one of the d-link execute commands, and Analyst shut down again.
I tried rebuilding indexes, and refreshing references, but then, ALL the Macros, and most of the other objects were also missing. :'(

Other models are working fine (and this particular model is one we've used for several years).  I'm working on restoring a back-up, but wondered if anyone else has had this type of issue?  If so, any advice or info you can give me is GREATLY appreciated.  I'd love to know why it happened, and how I can avoid it.

Was able to recreate this on a test model.  Deleting a d-link where:
  1) d-link was A>C
  2) d-link was to Production
  3) d-link was in a copied Analyst library, where the new Contributor App had NOT been created yet (still linking to the previous Contributor app).

Not sure which of these is important or not, but from now on I'll create and link to the new Contributor app before deleting any A>C d-links.


[0] Message Index

Go to full version