Planning & Consolidation > COGNOS Planning

Have to make multiple connections to ODBC

(1/2) > >>

On my dev/test system (10.2.2? - Install EN  Build EPANALYST when I open a D-Link which contains a SQL query I am asked for user id and password and the system connects (I know this because I get a message regarding changing to US English), so far so reasonable. However before the D-Link appears I have to repeat the user id password combination and then if I wish to run the update I get asked again!

My current live system asks for the user id and password once for a session.

Any ideas why Analyst doesn't hold onto the connection?

You might want to check your Cognos Planning Data source connection. Check if you created a signon that everyone group can use. Else it will need to authenticate the user for each session.

First of all, thank you for your interest, I had problems when posting the question and I thought it had got onto this server.

Re your reply - Which part of the connection should I look at? I have looked at Cognos configuration and ODBC driver setup and cannot see any group everyone.

Is your suggestion to look at the driver files or am I missing something (I probably am).

Thanks again,

I thought it had NOT got onto this server.

Problem solved

And, as is often the case, it was a simple solution.
There were two sql drivers referenced in the d-Links so the system did not know which one to open.

When I set all the d-links to refer to one driver (sql connection) they all open without having to enter the user and password, I assume because the credentials built into the query don't change.

Amazing how explaining a problem to someone else helps you get the solution yourself!!

PS How do I change the title of the thread to include the word solved?


[0] Message Index

[#] Next page

Go to full version