Author Topic: Missing Date levels in a published cube [Solved]  (Read 311 times)

Offline cognosjon

  • Community Leader
  • *****
  • Join Date: Jul 2006
  • Posts: 216
  • Forum Citizenship: +10/-2
Missing Date levels in a published cube [Solved]
« on: 13 May 2019 10:24:01 am »
Hi, I'm experiencing a strange issue with levels of my date (time) dimension disappearing within one of my cubes once its published.

I can see the hierarchies built within the category tree of transformer along with my special date categories,  but as soon as its published I lose all the levels.
I've checked all studios and they aren't visible.
The levels are working correctly on all the other dimensions in the cube.
For reference I'm using 11.0.13 and Transformer 11.

I've not seen this happen before and the only way i can then get them to return is to delete the dimension and recreate it, obviously this is something i would prefer to avoid.

Anyone come across this before or have any suggestions?

Thanks

« Last Edit: 14 May 2019 03:14:14 am by cognosjon »

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 10,734
  • Forum Citizenship: +640/-10
  • Cognos Software Muppet
Re: Missing Date levels in a published cube
« Reply #1 on: 13 May 2019 06:41:29 pm »
Hi, I'm experiencing a strange issue with levels of my date (time) dimension disappearing within one of my cubes once its published.

I can see the hierarchies built within the category tree of transformer along with my special date categories,  but as soon as its published I lose all the levels.
I've checked all studios and they aren't visible.
The levels are working correctly on all the other dimensions in the cube.
For reference I'm using 11.0.13 and Transformer 11.

I've not seen this happen before and the only way i can then get them to return is to delete the dimension and recreate it, obviously this is something i would prefer to avoid.

Anyone come across this before or have any suggestions?

Thanks

Hi Jon,

The mystery of the disappearing levels!! We might be able to solve this if you can share or describe what you see at the top of the member tree from within the reporting interface? My suspicion is that you have both the root category and the drill category set as visible, which really confuses the studios. Someone else asked a similar question recently, if it's of any help:

https://www.cognoise.com/index.php/topic,35627.0.html

Cheers!

MF.
Meep!

Offline cognosjon

  • Community Leader
  • *****
  • Join Date: Jul 2006
  • Posts: 216
  • Forum Citizenship: +10/-2
Re: Missing Date levels in a published cube
« Reply #2 on: 14 May 2019 03:13:28 am »
Thanks MF,

I passed the info on to my colleague that is looking into this and I got back the following : It worked!!!!!! I love MF!!!

Not sure how i missed the previous post about it though...
Thanks for your help....again.............

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 10,734
  • Forum Citizenship: +640/-10
  • Cognos Software Muppet
Re: Missing Date levels in a published cube
« Reply #3 on: 14 May 2019 11:44:19 am »
Thanks MF,

I passed the info on to my colleague that is looking into this and I got back the following : It worked!!!!!! I love MF!!!

Not sure how i missed the previous post about it though...
Thanks for your help....again.............

Hurrah! Always happy when problems have a simple solution! Thanks for the update Jon :)

MF.
Meep!

 



       
Twittear