Author Topic: "cmAuthenticateFailed CM-CAM-4005 Unable to authenticate. " during schedule run  (Read 7047 times)

Offline szinsg

  • Associate
  • **
  • Join Date: Jun 2019
  • Posts: 2
  • Forum Citizenship: +0/-0
Hi, Gurus,

Our Cognos 10.2.2 scheduler always hit below error:

CM-REQ-4159 Content Manager returned an error in the response header. The error "cmAuthenticateFailed CM-CAM-4005 Unable to authenticate. Check your security directory server connection and confirm the credentials entered at login." can be found in the response SOAP header. CM-REQ-4342 An error occurred with the client.

We checked CM-CAM-4005 error, most of the supports point it to password reset. So we decided to use service account to schedule reports to bypass the password expire issue. But this issue still happened after using service account, we have to set two schedulers for each report, the second scheduler was set to run 5-10 mins after the first scheduler. Most of the time, the first one fails, and the second one runs successfully.

More and more schedule requirements come in, it is hard for us to use such tricky way for maintenance.

Anyone know the root cause and how to fix it? Please advise, thanks a lot.

Offline szinsg

  • Associate
  • **
  • Join Date: Jun 2019
  • Posts: 2
  • Forum Citizenship: +0/-0
In cognos login page, we have to key-in LDAP password twice to login successfully, is it related to above CM-CAM-4005 issue happened during scheduling job?

Appreciate if anyone can give me some idea to solve this issue. Thanks a lot.

Offline CPina

  • Associate
  • **
  • Join Date: Jun 2021
  • Posts: 1
  • Forum Citizenship: +0/-0
Hi szinsg,

were you able to find a solution for the issue with credentials on schedule job?

please let me know if you have any hint.
thanks
Carlos