Author Topic: Sophos Blocking IBM Cognos Configuration 10.2.2  (Read 488 times)

Offline KRees

  • Associate
  • **
  • Join Date: Feb 2019
  • Posts: 1
  • Forum Citizenship: +0/-0
Sophos Blocking IBM Cognos Configuration 10.2.2
« on: 07 Aug 2020 12:00:57 pm »
We use a data warehouse to create student data reports which runs on IBM Cognos 10.2.2.  Sophos is somehow causing the Cognos Configuration service to fail.  Wondering if anyone else has experienced this issue and how they resolved it.

Here is what I have tried:

  • Created a new threat protection policy in Sophos to include a folder and process exclusions for D:\Program Files (x86)\ibm\cognos\c10\ and D:\Program Files\ibm\cognos\c10_64: Cognos Configuration failed
  • Stopped hitmanpro.alert in task manager as the data warehouse engineer was thinking that this component was causing the issue: Cognos Configuration failed
  • Uninstalled Sophos completely: Congos Configuration was successful with no failures
  • Re-installed Sophos and added a folder and process exemption for entire C:/, D:/, and E:/ drives on all involved servers: Cognos Configuration failed
  • Turned off each individual component/service on the local Sophos installation: Cognos Configuration failed every time

I looked at the cogserver.log and pogo_2020-08-06.log files. Everything points to failure at the com.cognos.pogo.reportservice.ProcessManager, which appears to be the external report server.  Doing some research I came across the following website: Control Center can not launch Cognos Report.  The article has the same error message I'm seeing in the cogserver.log file.  The resolution is to install the missing libraries, libgcc and libstdc++ so that LDD comes up clean against BiBusTkServerMain and BMTMDProviderMain.

  • Based on this information, I changed the Sophos policy to not prevent DLLs loading from untrusted folders and disabled Protect processes: Cognos Configuration failed


At this point, I have no clue what the issue is or how to fix it.  Has anyone else run across this or have ideas on what I should try next?  I have tried everything I can think of that would help pinpoint the root cause but am still coming up short.