Author Topic: UDA-SQL-0333 could not find TABLE in dictionary  (Read 317 times)

Offline BIengineer

  • Full Member
  • ***
  • Join Date: Sep 2020
  • Posts: 9
  • Forum Citizenship: +0/-0
UDA-SQL-0333 could not find TABLE in dictionary
« on: 30 Oct 2020 04:25:29 am »
I have two tables in my Database View - each of them from separate databases, with separate Data Sources.

When running "Test example" for each of them, the queries work and return data.

But when I implement an embedded general filter object on one of them using the other like:   Table1.Column in (Table2.Column) it gives the error in the headline, implicating that it now can't find Table2. Again, running separately they work, trying to query them against each other doesn't.

I have tried removing schema name from the Data Source properties, but this only removed the Schema name from the error message.

I have also tried adding this filter through parameter maps, which evaluate just fine using tables from the same database, but fail when trying to use tables from two different databases such as the above implemented one.


Is the problem in Cognos Content Store potentially? Or are there restrictions in FM that cause this?