If you are unable to create a new account, please email bspsoftware@techdata.com

Author Topic: How to troubleshoot performance and report execution time  (Read 1348 times)

Offline actcognosuser

  • Community Leader
  • *****
  • Join Date: Dec 2009
  • Posts: 197
  • Forum Citizenship: +0/-0
Hello,

We've been having issues with a report that otherwise runs for 6-8 mins.
The lag between report submit time and start time is 35-40 mins but report run time is 5 mins.
Are there any metrics that need to be monitored on the server? There's no Audit package configured.
The lag and performance issues is during peak hours.

Thanks in advance.

Offline dougp

  • Statesman
  • ******
  • Join Date: Jul 2014
  • Posts: 798
  • Forum Citizenship: +30/-1
Re: How to troubleshoot performance and report execution time
« Reply #1 on: 02 Sep 2021 07:22:35 pm »
Submit?  Does that mean the user clicks on the report or is that a scheduled run?
DQM or CQM

This seems like a long queue time, but the default queue time is 4 minutes.  I can't imagine why something would wait 35-40 minutes to start without failing first.

You'll want to check a few things.
Number of report processes
Number of reports per process
(during peak and non-peak hours)
Maximum queue time

...on the query service, report service, or batch report service, depending on what's actually being used.


More basically:  Verify the report you're investigating is actually the one the user is complaining about.  I have many reports with the same name.  I don't know how many times I ran off and investigated the most obvious report in the area of Team Content that user is likely to use and found no problems, only to find out they were talking about something in My Content.

Offline actcognosuser

  • Community Leader
  • *****
  • Join Date: Dec 2009
  • Posts: 197
  • Forum Citizenship: +0/-0
Re: How to troubleshoot performance and report execution time
« Reply #2 on: 03 Sep 2021 09:47:59 am »
Thanks Doug.

The user has tried both options, clicking and scheduling. Both have the same lag. The run time is erratic.
 
Are these metrics derived from the Cogserver.log? We do not have an audit package configured.
Please advise.

Number of report processes
Number of reports per process
(during peak and non-peak hours)
Maximum queue time

The report in question is in the team content and not my folders.

Offline dougp

  • Statesman
  • ******
  • Join Date: Jul 2014
  • Posts: 798
  • Forum Citizenship: +30/-1
Re: How to troubleshoot performance and report execution time
« Reply #3 on: 07 Sep 2021 02:01:20 pm »
Those are tuning settings in Cognos Administration.  Contact your Cognos Administrator.