If you are unable to create a new account, please email bspsoftware@techdata.com

Author Topic: Customization of Cognos Connection does not apply to portal pages  (Read 6766 times)

cogdev0703

  • Guest
Cognos version : 8.4

I am in the process of customizing the Cognos Connection portal. So far I have achieved the following:

1. Copied the Corporate style from the webcontent/skins folder and created a new style.
2. Created a new style in Cognos Adkministration and pointed it to the new folder.

So far, the style looks fine on Public Folders and My Folders. The complexity is as follows:
I have created a custom page that contains horizontal tabs. When I view this page in the standard Cognos styles like Business and Corporate, the display of the page is consistent with that of the Cognos Connection portal. In short, the style flows down into the custom page. Then I change the Cognos style to the new style I created. The same custom page doesn't quite follow the style of the portal. The display of the page is inconsistent with the display of the portal. On analyzing the HTML source code using IE dev tools, the page seems to be referring to some css file in /wsrp/fragments/resource/css/default.

HAs anyone faced this issue before, or does anyone know how to remediate this issue?

cogdev0703

  • Guest
This issue is specific to a portal page tab I created that is a multi-page dashboard. Our tab is a multi-page dashboard with multiple levels of horizontal tabs within it. The "out-of-the-box" styles show up correctly for all tabs. But when I change the style to the custom style 'my_style', only the top tab level shows up correctly. The lower one's that are part of the portal page show a blank white style very different to the skin setup.

Any pointer or help would be appreciated.