Author Topic: FM SQL - XQE-PLN-0012 column could not be found in the model  (Read 312 times)

Offline Sugs

  • Full Member
  • ***
  • Join Date: Jan 2011
  • Posts: 14
  • Forum Citizenship: +0/-0
I am writing some simple SQL in Framework manager writing back to a Teradata database. In the SQL I have created a new column called Diff and yet when i try to reuse that column as a filter later on in the code I get the error message above saying it does not exist. Can anyone shed any light on this?     

Online bus_pass_man

  • Statesman
  • ******
  • Join Date: May 2008
  • Posts: 318
  • Forum Citizenship: +34/-0
Re: FM SQL - XQE-PLN-0012 column could not be found in the model
« Reply #1 on: 12 Jul 2019 08:24:33 am »
I suspect that you're trying to over-complicate things and your filter expression could be created without too much fuss.  Have you just tried to create a filter with the required expression? 

If so, what results did you get?

If not, why not? 



Other things to consider:

1.  Write back isn't supported.
2.  If you need the column so bloody much why doesn't it already exist in your dw?
3.  Why are you writing a SQL statement?
4.  Assuming you really really really need to do such a thing, a normal SQL statement should allow you to create the column in the projection list.
5.  Have you tried creating a model query subject and create the column with an analogue to whatever expression you are trying to use and then use it as the basis for your filter?

 



       
Twittear