Author Topic: Occassionally we see the below error messages on scheduled job in cognos 8.4  (Read 13825 times)

Offline mahammad

  • Associate
  • **
  • Join Date: Jan 2013
  • Posts: 1
  • Forum Citizenship: +0/-0
Occassionally we see the below error messages on scheduled job in cognos 8.4 prod environment. What is causing it and how it can be fixed.
 
DPR-ERR-2077 The request failed because the associated report service process with pid 4088 is unavailable. Handler trace back: [the_dispatcher] com.cognos.pogo.handlers.performance.PerformanceIndicationHandler [the_dispatcher] com.cognos.pogo.handlers.logic.ChainHandler [service_lookup] com.cognos.pogo.handlers.engine.ServiceLookupHandler [load_balancer] com.cognos.pogo.handlers.logic.ChainHandler [lb_forwarder] com.cognos.p2plb.clerver.LoadBalanceHandler [batchreportservicechain] com.cognos.pogo.handlers.logic.ChainHandler [warptask_with_authenticate] com.cognos.pogo.handlers.logic.ChainHandler [do_batch_warp] com.cognos.pogo.handlers.logic.ChainHandler [warptaskmtaChain] com.cognos.pogo.handlers.logic.ChainHandler [warptaskmta] com.cognos.pogo.reportservice.BatchReportServerHandler

DPR-ERR-2056 The Report Server is not responding. Handler trace back: [the_dispatcher] com.cognos.pogo.handlers.performance.PerformanceIndicationHandler [the_dispatcher] com.cognos.pogo.handlers.logic.ChainHandler [service_lookup] com.cognos.pogo.handlers.engine.ServiceLookupHandler [load_balancer] com.cognos.pogo.handlers.logic.ChainHandler [lb_forwarder] com.cognos.p2plb.clerver.LoadBalanceHandler [batchreportservicechain] com.cognos.pogo.handlers.logic.ChainHandler [warptask_with_authenticate] com.cognos.pogo.handlers.logic.ChainHandler [do_batch_warp] com.cognos.pogo.handlers.logic.ChainHandler [warptaskmtaChain] com.cognos.pogo.handlers.logic.ChainHandler [warptaskmta] com.cognos.pogo.reportservice.BatchReportServerHandler

 here ocasionally my job is failing.most of the days the job running sucecssfully.but from last few days the job is failing ocasionally with the above two errors.for suppose after failing the job if i am running manuaaly then itz running fine.but everytime manually runs means itz burden on us.
do we have any exact sollution on this and how can be it fixed?

Online MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 11,202
  • Forum Citizenship: +662/-10
  • Cognos Software Muppet
It sounds a lot like this known defect:

http://www-01.ibm.com/support/docview.wss?uid=swg1PM56522

If this is your issue, upgrade to 8.4.1 with Fix Pack 5 to get it fixed.

Cheers!

MF.
Meep!

Offline ricky_ru

  • Community Leader
  • *****
  • Join Date: Nov 2012
  • Posts: 82
  • Forum Citizenship: +0/-0
I also saw the error. We use sdk program to submite report. Is there something wrong with the sdk problem. our version is cognos 10.2

messages><message><messageString>The server did something wrong</messageString></message><message><messageString>DPR-ERR-2077 Failed to forward the request because the associated external process with PID 9699456 is unavailable, either because the process is shutting down, or this was an absolute affinity request and the requested process does not exist anymore. For more information, enable the dispatcher and the external process detailed logs, and reproduce the conditions that caused the error.</messageString></message></messages>   http://www.ibm.com/xmlns/prod/cognos/reportService/201109/.absoluteHandler trace back: [the_dispatcher] com.cognos.pogo.handlers.performance.PerformanceIndicationHandler [the_dispatcher] com.cognos.pogo.handlers.logic.ChainHandler [service_lookup] com.cognos.pogo.handlers.engine.ServiceLookupHandler [load_balancer] com.cognos.pogo.handlers.logic.ChainHandler [lb_forwarder] com.cognos.p2plb.clerver.LoadBalanceHandler [reportservicechain] com.cognos.pogo.handlers.logic.ChainHandler [warp_with_authenticate] com.cognos.pogo.handlers.logic.ChainHandler [do_warp] com.cognos.pogo.handlers.logic.ChainHandler [warpmta] com.cognos.pogo.reportservice.ReportServerHandler<SOAP-ENV:Fault xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><faultcode>Server</faultcode><faultstring>The server did something wrong</faultstring><detail><bus:exception xmlns:bus="http://developer.cognos.com/schemas/bibus/3/"><severity>error</severity><errorCode>ReportServerHandler.missingProcess</errorCode><bus:message><messageString>DPR-ERR-2077 Fa

Offline IndyBob

  • Full Member
  • ***
  • Join Date: Oct 2013
  • Posts: 7
  • Forum Citizenship: +0/-0
Each day we run saved output for several hundred versions of the same report. Randomly 6 or 7 will fail. I see several error messages in the log file. There will be an entry in the log file ahead of these errors that say the report run was a success. I should also mention that we are running about 4,000 saved outputs each day. Only this report gives me any errors. I can run the batch in the evening without error so I expect it to be environmental but cannot pin down the issue.

[ServiceAPIImpl] Service exception: DPR-ERR-2056 The Report Server is not responding. Handler trace back: [the_dispatcher] com.cognos.pogo.handlers.performance.PerformanceIndicationHandler [the_dispatcher] com.cognos.pogo.handlers.logic.ChainHandler [service_lookup] com.cognos.pogo.handlers.engine.ServiceLookupHandler [load_balancer] com.cognos.pogo.handlers.logic.ChainHandler [lb_forwarder] com.cognos.p2plb.clerver.LoadBalanceHandler [batchreportservicechain] com.cognos.pogo.handlers.logic.ChainHandler [warptask_with_authenticate] com.cognos.pogo.handlers.logic.ChainHandler [do_batch_warp] com.cognos.pogo.handlers.logic.ChainHandler [warptaskmtaChain] com.cognos.pogo.handlers.logic.ChainHandler [warptaskmta] com.cognos.pogo.reportservice.BatchReportServerHandler

Audit.RTUsage.ms.MS               [ServiceAPIImpl] Woke up from TaskRunner [24AFEA9076727672014DCCD5F35D8D6F].wait


Audit.dispatcher.caf   Request         Warning      secure error - found userCapabilities
« Last Edit: 11 Jun 2015 08:42:19 am by IndyBob »