Author Topic: Cognos IWR socket errors  (Read 4742 times)

Offline Dev1975

  • Community Leader
  • *****
  • Join Date: Apr 2013
  • Posts: 112
  • Forum Citizenship: +0/-0
Cognos IWR socket errors
« on: 24 Feb 2014 05:50:11 am »
Hello All,

Again, sorry if this is in the wrong forum board but I'm not sure where else to put it.

Customer experienced the following error message on-screen when trying to access their Cognos IWR environment:

Unable to log on.
A network failure occurred while communicating with server "server_name".
Error encountered sending parameters to server. Please logon again.

The web browser page also shows the following error:

ERROR
The server is not available to process your request.
Enable the Impromptu Web Reports Server and then resubmit your request.

Customer has been able to resolve this by opening up the Configuration and then clicking "Validate" & "Apply" at the top level, however the Customer would like to know what initially caused this. Having checked through the IWR logs and the Windows Event logs, I found a number of socket errors. Quick bit of Googling suggests that this can be caused by a large load strain on the server processing IWR requests, though the Customer environment does not have a massive load strain on it.

Are there any particular "gotchas" related to this issue? Why would validating and applying the configuration resolve this? Are there any pointers that people can send me to look into further?

Many thanks,
Dev
« Last Edit: 24 Feb 2014 05:54:44 am by Dev1975 »