Author Topic: Upgrade from Cognos 8.4 to 8.4.1  (Read 1923 times)

Offline willsy

  • Associate
  • **
  • Join Date: Feb 2016
  • Posts: 2
  • Forum Citizenship: +0/-0
Upgrade from Cognos 8.4 to 8.4.1
« on: 09 Feb 2016 07:38:28 am »
Hi

We are currently running version 8.4 of Cognos. The server shows C8BISRVR-AW32-ML-RTM-8.4.27.78-0.

For some time now we have had a intermittent issue where we get a 'DPR-ERR-2077 The request failed because the associated report service process with pid nnnn is unavailable' when running reports.

I've done some research and found that we may need to upgrade to Cognos 8.4.1 FP3 onwards to fix this issue.

Would you agree with this?

If this is the required fix, could you please let me know how I should go about the upgrade from 8.4 to 8.4.1 FP3...

Do I need to uninstall the old version 8.4 and install new 8.4.1? Also where I can possibly get the upgrade files from for Windows? I contacted IBM, but they said that they cannot help as they do not support v8. They suggested upgrading to v10 and then they could assist.

Thanks

Will

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 10,475
  • Forum Citizenship: +633/-10
  • Cognos Software Muppet
Re: Upgrade from Cognos 8.4 to 8.4.1
« Reply #1 on: 09 Feb 2016 04:32:33 pm »
Hi

We are currently running version 8.4 of Cognos. The server shows C8BISRVR-AW32-ML-RTM-8.4.27.78-0.

For some time now we have had a intermittent issue where we get a 'DPR-ERR-2077 The request failed because the associated report service process with pid nnnn is unavailable' when running reports.

I've done some research and found that we may need to upgrade to Cognos 8.4.1 FP3 onwards to fix this issue.

Would you agree with this?

If this is the required fix, could you please let me know how I should go about the upgrade from 8.4 to 8.4.1 FP3...

Do I need to uninstall the old version 8.4 and install new 8.4.1? Also where I can possibly get the upgrade files from for Windows? I contacted IBM, but they said that they cannot help as they do not support v8. They suggested upgrading to v10 and then they could assist.

Thanks

Will

Hi,

To put this into perspective, your question is rather like saying "I'm running Windows 95 and I need to upgrade to Windows 98 to fix an issue. Where can I get Windows 98?"

Neither 8.4 nor 8.4.1 are supported by IBM these days. Both are pretty ancient builds - in the case of 8.4 pre-dating the IBM acquisition of Cognos. You should really consider upgrading to a more recent build of Cognos BI. Even if you were to upgrade to 10.1 or 10.1.1, these builds are scheduled to drop out of support in April this year so you wouldn't have a big support window. I'd be looking at Cognos 10.2.2 personally.

The only place you can legally get the software is from the IBM Passport Advantage downloads site. If IBM are telling you there's no option to download 8.4.1, you're out of options, sadly. You need to look at upgrading to a newer build.

Good luck!

MF.
Meep!

Offline willsy

  • Associate
  • **
  • Join Date: Feb 2016
  • Posts: 2
  • Forum Citizenship: +0/-0
Re: Upgrade from Cognos 8.4 to 8.4.1
« Reply #2 on: 10 Feb 2016 03:05:48 am »
Hi MF,

Thanks for the info, that's much appreciated.

Your comments are what I was thinking might be the case, so thanks for confirming!

Looks like an upgrade to the latest v10 is the only way forwards for this...

Cheers

Will.

Offline antexity

  • Senior Member
  • ****
  • Join Date: Jan 2011
  • Posts: 65
  • Forum Citizenship: +2/-0
Re: Upgrade from Cognos 8.4 to 8.4.1
« Reply #3 on: 15 Jan 2018 10:07:40 am »
I would like to hijack this thread for a question I have.  We are in the process to start the upgrade process to Cognos Analytics, finally.  In the meantime, our Cognos 8.4 environment is experience the same issues as above and Cognos 8.4.1 FP5 will address these issues.  Question is, do we have to upgrade to release 8.4.1 and then apply the Fixpacks?  Or does the fix packs contain the release of 8.4.1?

I was able to locate all the fix packs on passport advantage just not 8.4.1 release, hence my above question.

Thanks!

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 10,475
  • Forum Citizenship: +633/-10
  • Cognos Software Muppet
Re: Upgrade from Cognos 8.4 to 8.4.1
« Reply #4 on: 15 Jan 2018 10:20:18 am »
I would like to hijack this thread for a question I have.  We are in the process to start the upgrade process to Cognos Analytics, finally.  In the meantime, our Cognos 8.4 environment is experience the same issues as above and Cognos 8.4.1 FP5 will address these issues.  Question is, do we have to upgrade to release 8.4.1 and then apply the Fixpacks?  Or does the fix packs contain the release of 8.4.1?

I was able to locate all the fix packs on passport advantage just not 8.4.1 release, hence my above question.

Thanks!

Hi,

Cognos 8.4 and Cognos 8.4.1 were different installs, so you can't use fix packs designed for 8.4.1 to patch an install of 8.4.

I'm guessing upgrading to Cognos Analytics will eventually fix your issue, but in the meantime you either need an install of 8.4.1, or you need the relevant fix pack for 8.4 (if it was ever created).

Cheers!

MF.
Meep!

 


       
Twittear