Author Topic: ccl-bit-0005 a socket reported a communication error  (Read 418 times)

Offline s.aravindkumar

  • Full Member
  • ***
  • Join Date: Mar 2017
  • Posts: 24
  • Forum Citizenship: +0/-0
ccl-bit-0005 a socket reported a communication error
« on: 17 Jan 2018 12:21:20 am »
Hi ,

I successfully installed IBM Cognos Transformer 11.0 but when I try to to create a package or report i am getting a error as

"ccl-bit-0005 a socket reported a communication error"

cognos version is 11.0.7
Framework version  11.0.7
Transformer version 11.0

Thanks in Advance

Aravind Kumar Sekar

Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 10,331
  • Forum Citizenship: +623/-10
  • Cognos Software Muppet
Re: ccl-bit-0005 a socket reported a communication error
« Reply #1 on: 17 Jan 2018 03:20:24 am »
Hi ,

I successfully installed IBM Cognos Transformer 11.0 but when I try to to create a package or report i am getting a error as

"ccl-bit-0005 a socket reported a communication error"

cognos version is 11.0.7
Framework version  11.0.7
Transformer version 11.0

Thanks in Advance

Aravind Kumar Sekar

Sounds like it might be a configuration issue to me. Have you checked that the Cognos Configuration for Transformer is using the correct URIs for gateway and dispatcher?

Cheers!

MF.
Meep!

Offline s.aravindkumar

  • Full Member
  • ***
  • Join Date: Mar 2017
  • Posts: 24
  • Forum Citizenship: +0/-0
Re: ccl-bit-0005 a socket reported a communication error
« Reply #2 on: 18 Jan 2018 12:07:45 am »
Hi MFGF,

Thanks for the reply.

The Gateway URI and Dispatcher URI for External application for Cognos transformer

GATEWAY            :http://<servername>:9300/bi/v1/disp
DISPATCHER    :http://<servername>:9300/p2pd/servlet

and The Gateway URI and Dispatcher URI for External application for Cognos Server.

GATEWAY            :http://<servername>:9300/bi/v1/disp
DISPATCHER    :http://<servername>:9300/bi/v1/disp

I tried by changing the Dispatcher of Transformer same as its present in Cognos Server but it didnt work.So what I did is correct or some other changes I need to do.



Offline MFGF

  • Never knowingly correct
  • Super Moderator
  • Statesman
  • ******
  • Join Date: Jul 2005
  • Posts: 10,331
  • Forum Citizenship: +623/-10
  • Cognos Software Muppet
Re: ccl-bit-0005 a socket reported a communication error
« Reply #3 on: 18 Jan 2018 03:15:11 am »
Hi MFGF,

Thanks for the reply.

The Gateway URI and Dispatcher URI for External application for Cognos transformer

GATEWAY            :http://<servername>:9300/bi/v1/disp
DISPATCHER    :http://<servername>:9300/p2pd/servlet

and The Gateway URI and Dispatcher URI for External application for Cognos Server.

GATEWAY            :http://<servername>:9300/bi/v1/disp
DISPATCHER    :http://<servername>:9300/bi/v1/disp

I tried by changing the Dispatcher of Transformer same as its present in Cognos Server but it didnt work.So what I did is correct or some other changes I need to do.

Hi,

That sounds wrong to me. I'd expect your gateway to be http://<servername>:9300/bi/v1/disp and your dispatcher to be http://<servername>:9300/p2pd/servlet/dispatch in both configs

MF.
Meep!

 


       
Twittear