Author Topic: Event Studio parameters not passed to report!  (Read 210 times)

Offline bioCam

  • Senior Member
  • ****
  • Join Date: Aug 2010
  • Posts: 57
  • Forum Citizenship: +0/-0
Event Studio parameters not passed to report!
« on: 07 Nov 2018 08:39:54 am »
We are on 10.2.  The event was working and able to pass the parameters to the report, burst and email report to recipients until a change to the FM model.

Due to the FM model change many of the report data items were 're-mapped' to use new query subjects.  Report runs fine with correct results.  Event was modified as well and it triggers fine, burst and email report to recipients --- BUT the dates are not being passed to the report and therefore not showing results for the current year. 

Any help is much appreciated.  My last option is to re-create the report which I'd like to avoid as the report is in Production and used a quite a bit and also a complex report.  Thank you.

Regional Report has:
- 2 date prompts (pStartDate, pEndDate)
- jscript defaults dates to start / end of current year (ie 1 Jan 2018, 31 Dec 2018)
- Burst Options - key 'REGMANAGER', Burst Recipient 'EMAIL'
- Report view created called 'Report View of Regional Report'

Event Studio has:
1) Specify an event condition:  Email <> '' <space>
2) Specify the report to run: 'Report View of Regional Report'
     - Options:  Output in PDF, Burst checked
     - Prompt values: 2 calculated data items 'vStartDate', 'vEndDate' to pass to the report
3) Specify email to send: '[EMAIL]' and PDF attached
 

 


       
Twittear