Author Topic: Create new Data module - error  (Read 353 times)

Offline peewan

  • Senior Member
  • ****
  • Join Date: Aug 2019
  • Posts: 66
  • Forum Citizenship: +0/-0
Create new Data module - error
« on: 03 Aug 2020 12:13:41 pm »
Hi,

I combine 2 packages data using Data module.
When I use the new package to run the report,  I had an error "XQE-PVD-0002 the provider type "relation (OD)' is not supported in Dynamic Query Mode.
Any help?

Thanks a lot!

Offline bus_pass_man

  • Statesman
  • ******
  • Join Date: May 2008
  • Posts: 435
  • Forum Citizenship: +43/-0
Re: Create new Data module - error
« Reply #1 on: 03 Aug 2020 01:16:34 pm »
My supposition is that one or both of the source packages are set to use CQM rather than DQM.  The OD stands for your provider.  I think OD means ODBC.

At what point do you encounter this problem?   If you use objects from just one of the packages in a report do you encounter the problem?  If you create a module with just one of the packages do you encounter the problem?  I think that you will encounter the problem in all the cases. 

You will need to either migrate to DQM or accept that you can't use your packages embedded in a module.

https://www.cognoise.com/index.php?topic=33807.0