Author Topic: Cognos Viewer Customization Worries (Cognos 8.3)  (Read 35562 times)

Offline gurumeditation

  • Associate
  • **
  • Join Date: Jun 2008
  • Posts: 3
  • Forum Citizenship: +0/-0
Cognos Viewer Customization Worries (Cognos 8.3)
« on: 16 Jun 2008 09:28:11 am »
hey all,

i have been heavily customizing a cognos 8.3-installation via the "skins"-functionality for the last week, and all seemed to work fine (mainly cognos connection, query studio)…

however, today i ran into a major problem. i'm not very familiar with the cognos application(s) and only discovered the cognos viewer today by clicking around among the sample pages and tabs i created to test the new "skin" - and to my very personal horror ;-), "cognos viewer" now appears completely unstyled. when i view the underlying stylesheets, i run into lots and lots of

Code: [Select]
background-color: /* MISSING: background */;
and the like for both (URLs for the stylesheets)

Code: [Select]
cognos8/cgi-bin/cognos.cgi/dashboard/css/myportal?skin=mynewskin
cognos8/cgi-bin/cognos.cgi/dashboard/css/default?skin=mynewskin

i suspect that my newly created/modified styles (eg. in skins/newskin/ps/default.css) get somewhat parsed to build the stylesheets for cognos viewer, but that i have modified too much for cognos to parse those styles as it's used to, resulting in the "MISSING: ..." statements.

i use a lot of shorthand syntax in my css and already tried reverting most of those, but still no success.

any insight on this is highly appreciated, as the documentation doesn't really help - i hope i haven't overlooked anything obvious.

when i choose one of the default themes, the "cognos viewer" part appears "styled" again (stating the obvious, i know :-/) … to clarify what i want to describe by saying "cognos viewer part" (because i'm still in no way familiar with the application):

  • in "cognos connection", i created a "new page" (in "my folder") and put some of the standart cognos portlets (html viewer, rss viewer and the like) on it
  • in the last step of the "new page assistant", i registered a new tab for the new page
  • when i access the page by clicking the tab, it displays fine (as it's "rendered in cognos connection" as far as i understand)
  • when i view the page via the "my folders"-tab, it appears completely unstyled (saying "cognos viewer" on the top of the page)
  • when i view the html source and css-references, the two stylesheets with the "/* MISSING ... * */"-comments "appear"

for example, i gave the whole page a background-image (in skins/myskin/portal/default.css), which doesn't show up (in the "viewer") at all, as well as using some tricks to get hover-effects for the whole "cognos connection"-tabs; i faked round edges for the "mainheader3"-table and so on �" in short, our goal _was_ to make cognos do not look like cognos at all ;-).

i constantly tested what i assumed was "every part of cognos" (and they appear to be just fine) �" i just kind of "missed" that damn "cognos viewer" until now.

i guess i have to start from scratch and keep sticking to one of the default-skins (and it's css) as close as possible…?!

-----

i just did the following to narrow down possible problem areas �" and i'm hoping someone is still willing and able to get on that strange journey with me:

  • i copied the default cognos 8.3-"modern"-skin
  • renamed it, registered it as a new skin
  • opened it's /portal/default.css
  • and changed just the background-color for the BODY from #ffffff to #ff0000
  • changes show up in "cognos connection"
  • when i access "cognos administration" using that skin (with only that ONE CHANGE), it appears "unstyled" as described above

now it gets strange: when i REVERT those changes (read: JUST, ONLY ... changing the background-color back to #ffffff), the problem of the "unstyled" administration-area REMAINS. when if run a "diff" on the "default.css" in my skin-copy and its original in the unchanged default-skin-folder, it does not show a single difference. (same file encoding, line endings …)

before this, i thought that my "very custom" css changes caused those problems. now it seems i can make cognos go crazy just with one simple change in "default.css" �" leaving me clueless.

please forgive me for my general "cognos-n00b'ness" ;-) and that mess of a post.

thanks in advance,
peter

Darek

  • Guest
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #1 on: 16 Jun 2008 12:16:58 pm »
Could you elaborate more on the construct of your URLs? It seems strange to me, that you have some path references between cognos.cgi and the question mark.

Offline gurumeditation

  • Associate
  • **
  • Join Date: Jun 2008
  • Posts: 3
  • Forum Citizenship: +0/-0
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #2 on: 19 Jun 2008 04:44:28 am »
hey darek,

thanks for replying. as for the URLs, these

Code: [Select]
cognos8/cgi-bin/cognos.cgi/dashboard/css/myportal?skin=mynewskin
cognos8/cgi-bin/cognos.cgi/dashboard/css/default?skin=mynewskin

are the URLs where the CSS-files are retrieved (as shown via "View CSS" from within Firefox' Webdeveloper-Plugin).
Those Stylesheets lead me to the assumption that "Cognos itself" must be parsing some of the Skin-Stylesheets (and having problems with my modified styles), resulting in the aforementioned

Code: [Select]
/* MISSING ... */
references in the "generated" Stylesheets.

I sincerely hope this helps?!

Offline sebnob

  • Associate
  • **
  • Join Date: Jul 2008
  • Posts: 1
  • Forum Citizenship: +0/-0
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #3 on: 29 Jul 2008 03:10:15 pm »
I'm having the same problem here. I would like to know if you have any update on this.

It seem that the new dashboard portlet don't use the same mechanism for styling the the old stuff.
It also seem that the cognos administration section use this new multi-page portlet.

Offline vrishal

  • Full Member
  • ***
  • Join Date: Aug 2008
  • Posts: 12
  • Forum Citizenship: +1/-0
    • My Blog (CognosForAdmins)
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #4 on: 21 Aug 2008 10:25:42 am »
hi all,
   i have successfully been able to rebrand some parts of Cognos. One page that I am having problem is on the administration page. Does anyone know which file to edit to change the text on the Cognos Administration page to custom text? I have provided a screenshot if my question is unclear.

Also, I have a similar problem as peter. If I change the skin to my custom skin, the Cognos Administration page appears 'un-styled'. All of the other pages take my new skin without a problem. It is just this one page (and all of its components on that page) which are the problem.

Thanks in advance for your help.
-Vrishal
« Last Edit: 21 Aug 2008 10:29:28 am by vrishal »

Offline vrishal

  • Full Member
  • ***
  • Join Date: Aug 2008
  • Posts: 12
  • Forum Citizenship: +1/-0
    • My Blog (CognosForAdmins)
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #5 on: 22 Aug 2008 12:09:21 pm »
Peter,
   I don't know if you found a solution, but if you didn't, I was able to figure it out.

Here goes.
   The Cognos Administration page takes its html junk from the original skin css files, but it looks for directions from c8\webapps\p2pd\WEB-INF\fragments\applications\cogadmin\pages\adminconsole.xml.

    Also, if you have a custom skin that you created, make sure you go to c8\webapps\p2pd\WEB-INF\fragments\styles, make a copy of one of the existing xml files in there and rename it to the name of your skin and edit this to reflect your skin.

Let me know if you have any other questions.

-Vrishal


Offline manjari14

  • Associate
  • **
  • Join Date: Dec 2008
  • Posts: 3
  • Forum Citizenship: +0/-0
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #6 on: 02 Dec 2009 02:01:41 am »
Hi ,

Thanks Vrishal for the input on cognos Administration. I am trying to acheive the same with a logo for cognos administration header . I defined the new skin in the skin folder under the path mentioned and also changed the application.xml to read from new skin. But still the logo is not displayed. None of the changes are applied to header of the cognos page. Also I am unable to figure out what to change in adminconsole.xml. There is not skin entry provided as such there.

Version which I am using is 8.3

Could you help me.

Offline kderoos

  • Full Member
  • ***
  • Join Date: Apr 2009
  • Posts: 13
  • Forum Citizenship: +2/-0
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #7 on: 22 Mar 2010 10:10:41 am »
I'm running into the same thing and was wondering if you have found a solution?

Specifically, I have:
1. Copied and renamed the Corporate Skin located at \c8\webcontent\skins\
2. Copied and renamed corporate.xml located at \c8\webapps\p2pd\WEB-INF\fragments\styles\skins
3. Created a new style in Cognos Administration
4. Edited color schemes in following files: \c8\webcontent\skins\mystyle\shared\banner.css, \c8\webcontent\skins\mystyle\portal\default.css, and \c8\webcontent\skins\mystyle\viewer\CRN.css

Things look good at the Cognos Connection screen and when navigating around in Public Folders and My Folders.  When I select Launch, IBM Cognos Connection though, it reverts back to the traditional Corporate color scheme.

Using FireFox's Web Editing tools, I see that when I move to IBM Cognos Administration page, it uses a different default.css file than the one I've edited (and the one that Cognos is using when I'm in Public folders).  The thing is, I cannot figure out what default.css file it is using.

Any thoughts?  Thanks in advance.

Offline KimEBN

  • Associate
  • **
  • Join Date: Apr 2010
  • Posts: 1
  • Forum Citizenship: +0/-0
Re: Cognos Viewer Customization Worries (Cognos 8.3)
« Reply #8 on: 22 Apr 2010 09:04:30 am »
Hi kderoos,
I'm working on some skinning customization in Cognos 8.4 and experienced similar problems, this is how I solved it.

The Cognos Administration style needs to be changed in the following file:

<c8 install dir>\webapps\p2pd\WEB-INF\fragments\applications\cogadmin\application.xml

There is a value there, 'skin="corporate"', which you need to change to the value of your custom skin. Also, if you want to make changes to the layout in the Cognos Administration this should be done in the following file:

<c8 install dir>\webapps\p2pd\WEB-INF\fragments\styles\skins\<yourskin>.xml

Hope this helps - it work for me. :)

 


       
Twittear