If you are unable to create a new account, please email support@bspsoftware.com


DecisionStream error Message in build

Started by vetteheadracer, 11 Jan 2006 10:40:32 AM

Previous topic - Next topic


I have a DS Build which was working fine, I added a field, dropped the table because it was missing the new field and since then I get this error message.

[PROGRESS   - 16:31:38] Validating Build Definition
[PROGRESS   - 16:31:38] Processing Reference Data
[PROGRESS   - 16:31:38] Processing Dimension Domains
[PROGRESS   - 16:31:38] Processing Data
[DETAIL     - 16:31:38] waiting to process rows
Unexpected error ALLOC_FAILURE detected; Y:\src\decisionstream\c_src\dbms\uda\dsuda.c [6067]
[PROGRESS   - 16:31:41] Build 'DM_CRM_PART_1' Failed
databuild -- failed (11-Jan-2006 16:31:41)

My build is ultra complicated as it has 18 unioned select statements in it! However it worked fine and ran quicly until I added this new field which Parses correctly so I know the SQL is correct, the re-created table has all of the correct fields in the table and all have the correct sizes for the largest values to be held in each field.
Hope someone knows what the ALLOC_FAILURE error message actually means.

It's an Oracle 9+ (can't remember the exact version).



Why are you using a union query?

Couldn't you achieve the same result by having many datastreams and letting the build do the merge?