Author Topic: Upgrade issue from cognos 11.0.9 to 11.0.13  (Read 893 times)

Offline kevinl1210

  • Associate
  • **
  • Join Date: Nov 2018
  • Posts: 1
  • Forum Citizenship: +0/-0
Upgrade issue from cognos 11.0.9 to 11.0.13
« on: 08 Nov 2018 08:28:01 pm »
Tried to upgrade the existing cognos 11.0.9 to 11.0.13 using the over-the-top method, after the installation, I opened the cognos configurations and didn't see the prompt of "older versions of Configuration files were found and configuration files have been upgrade to the latest version".
I felt it really weird since I usually see this prompt from previous upgrade of 11.0.5 to 11.0.9  :'(
Also I tried to test my cognos 11.0.13 configurations, it displayed error from "Checking password of JVM trust store", open the detail will see [ERROR] CAM-CRP-1613 Not able to retrieve configured password.
Can anyone help me figure out what's wrong with this.  :'(
Many thanks in advance. :)

Offline elporo

  • Associate
  • **
  • Join Date: Dec 2018
  • Posts: 1
  • Forum Citizenship: +0/-0
Re: Upgrade issue from cognos 11.0.9 to 11.0.13
« Reply #1 on: 04 Dec 2018 08:23:32 am »
It works for me :  (Renew the keys)

Offline GrumbleNuts

  • Senior Member
  • ****
  • Join Date: Dec 2016
  • Posts: 63
  • Forum Citizenship: +2/-0
Re: Upgrade issue from cognos 11.0.9 to 11.0.13
« Reply #2 on: 04 Dec 2018 06:35:45 pm »
I can confirm this.

I recently go this exact same issue upgrading from 11.0.11 to 11.1.1

I also used the exact link and steps above and it fixed my issue.

Offline DavidHull

  • Full Member
  • ***
  • Join Date: Jul 2018
  • Posts: 8
  • Forum Citizenship: +0/-0
  • Not all who wonder are lost ;)
Re: Upgrade issue from cognos 11.0.9 to 11.0.13
« Reply #3 on: 04 Jan 2019 12:20:35 pm »
Hi there, we upgraded from 11.0.12 to 11.0.13 and experienced a number of issues (WinServ 2012 R2 on an Oracle 12 Content Store).

First one was right after the upgrade, "[JVM trust store test] [ ERROR ] CAM-CRP-1613 Not able to retrieve configured password."

Once we regenerated our Crypto Keys, we were able to restart our services (2 CTM's and 3 Dispatchers).

We ran into some severe behavior after that that has been corrected with IBM's fix pack (ca_srv_win64_11.0.13.18121321)

The gist of it had to do with 'relative' paths vs 'absolute' paths.
No firm details yet, but basically, the relative path descriptors were not 'located' where they thought they were in the folder tree structure.
Suddenly our images were inaccessible - we had to edit some of the config to an absolute reference to fix that.
That upgrade issue also caused the inability to edit prompts set on scheduled reports - everything was greyed out with no way to edit anything.

The FP has corrected most of the issue, but we're still seeing a number of failures when it comes to saved Analysis Views.
We are working through those by basically opening the View, and saving it in place.
That seems to be correcting the broken references back to the originating cube.

More to follow as we work through it.
« Last Edit: 04 Jan 2019 12:28:21 pm by DavidHull »

Offline dougp

  • Statesman
  • ******
  • Join Date: Jul 2014
  • Posts: 376
  • Forum Citizenship: +19/-1
Re: Upgrade issue from cognos 11.0.9 to 11.0.13
« Reply #4 on: 04 Jan 2019 01:30:29 pm »
I have always run into problems when trying to install Cognos over an older version.  Yesterday I upgraded my QA environment from 11.0.7 to 11.0.13.  It went very smoothly.

Here is my current process (very high-clip):

  • back up databases
  • (If you have heavily customized by modifying xml files or creating features using SDK, you'll want a backup of that, too.)
  • uninstall Cognos 11.0.7
  • delete any remaining Cognos artifacts (<install_location>\analytics, <install_location>\sdk, <install_location>\samples, etc.)
  • reboot
  • in services.msc, make sure the IBM Cognos service is gone.  If not, open an administrator command line and run sc delete "IBM Cognos".
  • install Cognos 11.0.13
  • open Cognos Configuration and configure the same as 11.0.7 (including databases)
  • start service -- fail -- update service credentials -- start service
  • modify and run CA_IIS_Config.bat (because I use IIS) --
  • make any other modifications to Cognos (tuning, logging, etc.) that were in 11.0.7 (but much of this is in the Content Store, so this is just a double-check.)